<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
OIE Upgrade Blocked by SAML Device Trust for iOS
Administration
Okta Classic Engine
Okta Identity Engine
Overview

The following reconfiguration has been identified as part of the preparation needed to perform the upgrade to Okta Identity Engine (OIE). Note that additional Okta features may require reconfiguration or be disabled in order to complete the upgrade. An upgrade to OIE cannot proceed if Security Assertion Markup Language (SAML) based Device Trust for iOS is enabled.

Applies To
  • Okta Identity Engine (OIE) Upgrades
  • Device Trust
  • Security Assertion Markup Language (SAML)
Cause

The upgrade to OIE cannot be scheduled because SAML-based Device Trust is not a supported feature on OIE. This feature must be disabled before the upgrade can proceed.

Solution

The steps to resolve this upgrade blocker depend on the current configuration:

  • If SAML-based Device Trust is not configured

If this feature is present but not configured in the organization, open a ticket with Okta Support to request that the feature be disabled.

 

  • If SAML-based Device Trust is configured

If this feature is actively configured, it must be disabled before opening a support ticket.

    1. Follow the guidance in the Management attestation for mobile devices to disable Mobile Device Trust.

    2. After Mobile Device Trust is disabled, open a ticket with Okta Support to request that the feature be disabled.

 

Related References

Loading
OIE Upgrade Blocked by SAML Device Trust for iOS