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Cisco Webex Provisioning Error "The request could not be understood by the server due to malformed syntax"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When provisioning users, user creation can fail for several reasons that are not clear from the error message received:

The request could not be understood by the server due to malformed syntax.
Bad Request. Errors reported by remote server: One (or more) of the arguments is invalid.

Applies To
  • Provisioning
  • Cisco Webex
Cause
  • The username is not in an email address format.
  • The following Multivalued attributes are mapped PhoneNumber for mobile and work, as well as Address. Those attributes are not supported by Okta because the operation for PATCHPUT, or DELETE is not passed by the Okta application to Webex.
Solution

These are the only supported Attributes:

  • userName (this is controlled in the Sign On tab of the Webex Okta App)
  • displayName
  • name.familyName
  • name.givenName
  • externalId (this is synched back to Okta after successful provisioning)
  • title

Please make sure that only the supported Cisco Webex app attributes are mapped and found in the Okta Cisco Webex app user schema in the Okta Profile Editor. Any unsupported Cisco Webex app user attributes (with a custom app attribute type) should be unmapped and removed from the Okta Profile Editor, as Okta does not support partial profile push to an external application

NOTE: Once the above causes are resolved, a case must be opened with Cisco Webex Support to provision users again successfully. They will then remove the cached entries, allowing for successful provisioning.

 

Related References

Recommended content

Documentation
HTTP status codes
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Cisco Webex Provisioning Error "The request could not be understood by the server due to malformed syntax"