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Cannot Drag Recipient into Send Email Card in Okta Workflows
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

Certain cards and inputs in Okta Workflows will only accept specific data types.

It may not be possible to save the flow if the input is invalid - Invalid type conversion. Here's an example of what that might look like:

Save Failure
Your flow can't be saved because it is invalid.
Correct the problems and try again.


Workflow Save Failure

NOTE:

  • The red text in the label of the To field of the O365 Send Email card indicates an issue with that input.
  • Red labels in the flow are a good indication of where the problem with the configuration might be.
Applies To
  • O365 Mail - Send Email action
  • Gmail - Send Email action
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
Cause

The To and CC fields of both the Gmail and O365 Send Email cards accept a List of text values.

It is possible to drag a text value into these inputs, even though they accept a List.

Solution

To create a suitable input for the Gmail or O365 Send Email cards, use the following steps:

  1. Add a List - Construct card.
  2. Drag or type the e-mail addresses into the List - Construct card created in Step 1. 
  3. Set the input types to Text.
  4. Set the output type of the List - Construct to a list of Text.
  5. Now should be possible to drag the list of recipients from the output of the List - Construct card into the ToCC, or BCC fields of the O365 and/or Gmail - Send Email cards.

Workflows

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Cannot Drag Recipient into Send Email Card in Okta Workflows