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Microsoft Office 365 Provisioning Error in Okta "These licenses have only suspended (unassignable) seats left"

Okta Integration Network
Okta Classic Engine
Okta Identity Engine

Overview

When provisioning users to Microsoft Office 365, the provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <userName> to app Microsoft Office 365 failed: Unable to assign licenses to the user. These Licenses have no available seats: "Office 365 Business - <O365 license name>. These licenses have only suspended (unassignable) seats left: Please fix this on the Tasks Page."

 

Error Message

Applies To

  • Microsoft Office 365
  • Provisioning
  • Okta Classic Engine
  • Okta Identity Engine (OIE)

Cause

The automatic user assignment fails because there are no free license seats available for Microsoft Office 365. One common reason is that deactivated Microsoft users still keep the licenses.

Solution

Follow the steps below to resolve the error:

  1. Verify license counts in the Microsoft Office 365 Administration Portal, and confirm that all deactivated users in O365 have had their licenses removed to replenish the counts.
  2. Once the impacted license seats are available in O365, the task in Okta can be retried, or alternatively, a modification can be made to the appuser profile to trigger a profile push and successfully link the users.

 

NOTE: Okta itself doesn’t control or prioritize which users receive licenses when the number of available Microsoft 365 seats is less than the number of users being assigned. The license assignment request is sent to Microsoft 365 for each user, and Microsoft determines whether a seat is available at that moment.

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Okta Support - Microsoft Office 365 Provisioning Error in Okta "These licenses have only suspended (unassignable) seats left"