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Error "An object with this field already exists in the current organization" when Creating Okta-Mastered Accounts

Okta Classic Engine
Okta Identity Engine
Administration

Overview

When creating Okta-mastered accounts, users may see the following error below the username field, even though the username appears to be unique:

An object with this field already exists in the current organization

 

Applies To

  • Okta Mastered Users
  • Self Service Registration

Cause

The Self Service Registration feature has been enabled for the Okta tenant.  When this feature is enabled:

  • Okta will enforce uniqueness for all primary email addresses.
  • Okta automatically uses the email address as the end user’s username (hence the error in the Username field).

Solution

Make sure that there are no other users with the same primary email address, or recreate the user with a unique email address.

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Okta Support - Error "An object with this field already exists in the current organization" when Creating Okta-Mastered Accounts