<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Error "An object with this field already exists in the current organization" when Creating a New User Account
Okta Classic Engine
Okta Identity Engine
Administration
Overview

Okta Admin may run into the following error when creating a new user account:

An object with this field already exists in the current organization.

 

Applies To
  • Administration
Cause
  • The Okta username must be unique. 
  • While the email address does not have to be unique, the email address attribute cannot match the Okta username of another user.
  • The option Value must be unique for each user is enabled for a specific attribute (available for all other attributes apart from the username).
Value must be unique for each user option
Solution
  • Use an email address that does not match the Okta username of another user, or change the Okta username to remove the conflict.
  • Navigate to Okta Admin Console >  Directory > Profile Editor User (default). Search for the desired attribute and click on the sign. A pop-up will open from where the Value must be unique for each user option can be turned off (See print screen in the Cause section).
Profile Editor

 

NOTE: There is a feature flag that can be disabled to allow users to be created with the same email/username. Please reach out to Okta Support for more information if necessary.


 

Loading
Error "An object with this field already exists in the current organization" when Creating a New User Account