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Error "400 Bad Request - Bad SAML Request" when Signing in to the TeamViewer App
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

This article provides a solution for the situation where the TeamViewer SAML authentication fails with the error:

 400 bad request

 

Applies To
  • TeamViewer

  • Windows systems

Cause

By default, the TeamViewer client will use an embedded Internet Explorer browser for identity provider authentication. Internet Explorer allows a hard limit of 2083 characters in the SAML request URL.

Solution

If the default browser is used by the operating system instead of an embedded browser, change the following registry key in the Windows Environment:

  • HKEY_CURRENT_USER\Software\TeamViewer\SsoUseEmbeddedBrowser = 0 (DWORD)

The TeamViewer client needs to be restarted after creating or changing the registry.


Related References

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Error "400 Bad Request - Bad SAML Request" when Signing in to the TeamViewer App