<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
ShareFile SP-Initiated Login Error "400 bad request: Bad SAML"
Single Sign-On
Administration
Okta Identity Engine
Overview
When a user is performing an SP-initiated login from ShareFile, they see the following error message:

400 bad request: Bad SAML.
 
Applies To
  • ShareFile
  • Single Sign On (SSO)
  • Service Provider (SP)-Initiated
Cause
This is caused by the SP-Initiated Auth Context configuration on the ShareFile side being set incorrectly.
Solution

Set the SP-Initiated Auth Context on the ShareFile side to Unspecified and Minimum, as shown below:

SP-Initiated Auth Context

 

Loading
ShareFile SP-Initiated Login Error "400 bad request: Bad SAML"