Zoom Deprovisioning "Error while deactivating user: Forbidden. Errors reported by remote server: Current login user does not have permission: User:Edit" in Okta
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Zoom deprovisioning flow fails with the following error visible in the Okta dashboard:

Error while deactivating user <username>: Forbidden. Errors reported by remote server: Current login user does not have permission: User:Edit
 

Error

Applies To
  • Zoom
  • Provisioning
  • Error
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
Cause

The permissions of the account used for creating the API connection are incorrect on the Zoom side.

Solution
  1. Refer to Okta User Management with Zoom. On the Zoom side, verify the permissions for the account used to create the API connection.

  2. Go to the Okta admin panel and navigate to Applications > Applications > Zoom > Provisioning > Integration > Edit.

  3. Click Re-authenticate with Zoom. Sign in to the Zoom account with the Zoom admin's or owner’s credentials.

    Integration 

  4. On the Provisioning page in Okta, a message confirming successful authentication will be seen. Click Save.
  5. Afterward, try deprovisioning the user again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed deprovisioning tasks should appear under Tasks

  6. After identifying the failed task for the user to be retried, click Retry Selected.

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