Zendesk Provisioning "Error while verifying if user <username> exists: 404 Not Found: "{<EOL> "error": {<EOL> "title": "No help desk at <name>.zendesk.com",<EOL> "message": "There is no help desk configured at this address"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Zendesk provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Zendesk failed: Error while verifying if user <username> exists: 404 Not Found: "{<EOL> "error": {<EOL> "title": "No help desk at <name>.zendesk.com",<EOL> "message": "There is no help desk configured at this address. This means that the address is available and that you can claim it at http://www.zendesk.com/signup"<EOL> }<EOL>}<EOL>"
 

Error message

Applies To
  • Zendesk
  • Provisioning
  • Error
Cause

This error is generated because the Zendesk company name is incorrect in the Applications > Applications > Zendesk > General tab. 

Solution

Please follow the below video or steps: 


 

  1. In Okta Admin Console, navigate to Applications > Applications > Zendesk > General and click Edit.
  2. Then, enter the correct Zendesk company name and save the change. 

For example, if logging into http://acme.Zendesk.com/login,
Enter: acme

  1. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks
  2. After identifying the failed task for the user that should be retried, click on Retry Selected.

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