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Workday Termination Date Attribute Not Updating
Okta Classic Engine
Okta Identity Engine
Lifecycle Management
Okta Integration Network
Overview

Recently implemented Workday field overrides to retrieve the Termination_Date attribute to Okta are not appearing to update expectedly. Fetching the locations of Workday users results in the following error message in the Okta System Logs:


Processing error occurred. The task submitted is not authorized. 

Applies To
  • Workday
  • Universal Directory
Cause

If fetching the location of users fails, this will prevent the proper values of the Termination_Date attribute from updating accordingly.

Solution

When Okta imports user terminations, it does so by performing three different tasks:

  • Fetching the locations for the users (this is done so the users are terminated according to their time zones on the day of the termination).
  • Fetching the missing workers (the people found in a termination state and are not active workers).
  • Merging workers and terminations.

If fetching the location of users fails, this will prevent the proper values of the Termination_Date attribute from updating accordingly. To help resolve this issue, the integration account leveraged for the Okta/Workday integration must have the proper permissions to fetch locations via Workday.


Related References

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Workday Termination Date Attribute Not Updating