Workday Import Error: "Unable to fetch provisioning groups from Workday: Processing error occurred. The task submitted is not authorized."
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Workday import fails with the following error:

 

An error occurred during import
Unable to fetch provisioning groups from Workday: Processing error occurred. The task submitted is not authorized.

 

Import Error

Applies To
  • Workday
  • Import
  • Provisioning
Cause

The service account used for connecting the Workday integration does not have the correct permissions.

Solution
  1. Use the Workday Provisioning - Grant permission to an Integration System User documentation as a reference.  
  2. On the Workday side, verify the permissions for the account used to create the API connection. This can be achieved by contacting the Workday Support team.
  3. Open an incognito window in the browser and access the Okta tenant.
  4. Go to the Okta Admin Panel and navigate to Applications > Applications > Workday > Provisioning > Integration > Edit.
  5. Verify that the entered Workday credentials are correct, then click Test API Credentials.
  6. Verify the connection was successful, and then click Save.
  7. Then navigate to Applications > Workday > Import > attempt the import again.

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