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Windows Desktop MFA - Users Unable to Login when "UseDirectAuth" Is Enabled
Okta Identity Engine
Okta Device Access
Overview

This article details a known issue with a Windows Desktop MFA configuration that is available with the release of Okta Verify 5.4.

The conditions for this errant behavior would be a user that has not enrolled an authenticator and "UseDirectAuth" has been enabled on the local machine. Even though the "MaxLoginsWithoutEnrolledFactors" limit is not been reached, the user can still be blocked from login. If the device is online, end users will always be asked to authenticate with online factors, even when an offline factor is enrolled or allowed.

Applies To
  • Okta Identity Engine (OIE)
  • Okta Device Access - Desktop MFA
  • Windows Okta Verify
Cause

This is a known issue introduced with the "UseDirectAuth" functionality and Okta Verify version 5.4.

Solution

Okta Product Engineering is aware of this errant behavior and plans to deploy a patch in a future Okta Verify release. 

 

Workarounds

  • Upgrade Windows Okta Verify client to 6.1.1
    • This Okta Verify version adds a Skip for Now button to the login page for users that have not yet logged into the device.
  • Pre-enroll Authenticators for new users.
  • Take the device offline before login. 
    • The end user may perform an offline login, then proceed to bring the local machine back online and enroll an authenticator.
  • Disable "UseDirectAuth" from the local machine (Default) and reboot the local machine.
    • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Okta\Okta Device Access\UseDirectAuth : REG_DWORD = 0
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Windows Desktop MFA - Users Unable to Login when "UseDirectAuth" Is Enabled