Users Receiving Email Verification Requests from Okta (email.crossOrgSamlEmailVerification)
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses an email verification request that users receive from Okta. The email contains the following text:

 

To verify your email address, please click the following link:


The email that the users might receive

 

 
Applies To
  • Self Service Apps
  • End-user Dashboard
Cause

This email verification is a security measure for specific Okta-proprietary applications, such as the Okta Support Center application. The system verifies each user's registered email address when they first access one of these applications to ensure the email address is valid.

Solution

This email verification is expected behavior and does not indicate an error.

When a user accesses an Okta-proprietary application like the Okta Support Center for the first time, the system sends a one-time verification email to the user's registered email address. If the user's email address is changed after the initial verification, the system requires a new verification the next time the application is accessed.

Prompt for email verification

Administrators can locate these email delivery events in the System Log.

  1. Navigate to Reports > System Log.

  2. Enter the following query in the search bar:

    debugContext.debugData.category eq "email.crossOrgSamlEmailVerification" and eventType eq "system.email.delivery"

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