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Users on Unmanaged Devices Receive an Erroneous MDM Remediation Message
Devices and Mobility
Okta Identity Engine
Overview

This article reviews a known issue where an end-user may be shown an erroneous "Additional setup required" remediation message when an unmanaged device attempts to access a resource protected by a managed device authentication policy. The message may reference the incorrect device management solution and direct to an unrelated enrollment site.

Applies To
  • Okta Identity Engine (OIE)
  • Android
  • iOS
  • macOS
  • Windows
  • Okta Verify
Cause

This occurs in environments where multiple MDM configurations for the same platform exist. When more than one device management configuration exists for the same platform, Okta Identity Engine uses the earliest created configuration to generate the remediation message. As such, the message may include the incorrect MDM solution names and enrollment links.

Solution

Follow these steps to prevent or reduce the impact of incorrect remediation messages:

  1. Open the Okta Admin Console.
  2. Navigate to Security > Device Integrations > Endpoint Management.
  3. Review device management configurations for each Platform.
  4. Confirm whether multiple configurations exist for the same platform with different solutions.

Endpoint Security

  1. Consolidate configurations per platform when possible to eliminate conflicts.
  2. Adjust authentication policies to reduce dependency on remediation for unmanaged devices (for example, create individual policies for unmanaged devices).
  3. Test changes with unmanaged devices to verify message accuracy.

 

Related References

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    Users on Unmanaged Devices Receive an Erroneous MDM Remediation Message