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User Email Updates Not Syncing from Okta to Tableau
Okta Identity Engine
Universal Directory
Overview

There are a couple of use cases where the user's email is getting changed; sometimes it's the first name/last name, sometimes it's the email domain. When the user's email is changed in Okta, usually this change would push down to the downstream app if the mapping of email is properly configured. But in some apps, this is not the case, like Tableau. 

 

Even in Syslog, it shows "Updated user application property" is successful for attribute userName and email; however, in Tableau, it did not reflect that change. 

Applies To
  • User profile update
  • Lifecycle Management
  • Tableau Cloud
  • Okta Identity Engine (OIE)
Cause

This is expected behavior because Tableau did not support email attribute change. An email address is an immutable field in Tableau Cloud. When a user's email address changes, there is currently no way to update the existing Tableau Cloud user account.

 

For more details please refer to: Unable to Provision User E-mail Changes to Tableau Cloud Through Azure, Okta or OneLogin SCIM v2.0

Solution

Manually unassign the user in the Admin Console for Tableau Cloud and reassign the user which would remove the existing user in Tableau Cloud and redo the provisioning so the new email will be used. 

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User Email Updates Not Syncing from Okta to Tableau