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User App Assignment is Missing
Okta Identity Engine
Lifecycle Management
Overview

A scenario has been encountered where a user App Assignment appears to have failed. Specifically, the user is added to a group, and the group is added to an app, but the user assignment is missing from the User Interface (UI).

Applies To
  • Okta Group App Assignments
  • Okta Identity Engine (OIE)
  • Lifecycle Management (LCM)
Cause

The user has duplicate app assignments both an "Active" and "Inactive"  statuses.

Solution

This issue is resolved by performing the following steps via Postman or Rockstar API Explorer.

 

  1. Perform a PATCH request to /api/v1/apps/{appId}/users/{userId} with the body [{"op": "replace", "path": "/scope", "value": "USER"}] to convert the group assignment to an individual assignment.
  2. Perform a DELETE on /api/v1/apps/{appId}/users/{userId} to remove the user from the app.
  3. From the Okta Admin UI console individually add the user to the App and then convert it back to a Group assignment. 
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User App Assignment is Missing