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Uploaded Background Image for Okta Sign-In Page Is Not Visible on Custom Brand
Okta Classic Engine
Okta Identity Engine
All Engines
API Access Management
Overview

This article discusses how to display the uploaded background image on the customized sign-in page when it is not displaying on a custom brand.

uploaded background is not displaying

Applies To
  • Customization
  • Custom URL Domain
  • Okta Hosted Widget
  • Sign-In Page
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause

This is caused by the signInPageTouchPointVariant value for the Theme still being set to "OKTA_DEFAULT" instead of "BACKGROUND_IMAGE":

theme_oktadefault

 

Solution

Use Brands API to update the theme to change the signInPageTouchPointVariant value to "BACKGROUND_IMAGE":

PUT https://{OktaDomain}/api/v1/brands/{brandId}/themes/{themeId}
{
        "primaryColorHex": "#1662dd",
        "primaryColorContrastHex": "#ffffff",
        "secondaryColorHex": "#ebebed",
        "secondaryColorContrastHex": "#000000",
        "signInPageTouchPointVariant": "BACKGROUND_IMAGE",
        "endUserDashboardTouchPointVariant": "FULL_THEME",
        "errorPageTouchPointVariant": "BACKGROUND_IMAGE",
        "emailTemplateTouchPointVariant": "FULL_THEME"
}

theme update request

 

Once updated, the background image can be seen in the preview on Customizations > Brands > Sign-in Page and on the sign-in page.

 

Preview on the Okta Environment > Sign-in PageUser Sign-in Page
brands updated themesign-in page

 

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Uploaded Background Image for Okta Sign-In Page Is Not Visible on Custom Brand