Unexpected Internal Server Error During Windows Okta Verify Enrollment
Last Updated:
Overview
This article addresses an error that occurs during Windows Okta Verify enrollment. After entering the organization's URL and clicking Next, a browser window opens and immediately displays the following error message:
There was an unexpected internal server error, please try again.
No related events are recorded in the System Log.
Applies To
- Okta Identity Engine (OIE)
- Windows Okta Verify
Cause
This error is caused by the system's default browser being set to the unsupported Microsoft Edge Legacy (EdgeHTML) browser.
Solution
Microsoft Edge Legacy (EdgeHTML) is not a supported browser for Okta Identity Engine (OIE) enrollments. The system's default browser must be changed to a supported browser, such as the Chromium-based version of Microsoft Edge, to resolve this issue.
