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Unable to Suspend or Deactivate Service Accounts Managed by Okta Privileged Access

Okta Classic Engine
Okta Identity Engine
Universal Directory

Overview

When an Okta user is designated as a service account and managed by Okta Privileged Access, "Suspend" and "Deactivate" under the "More Actions" context menu are greyed out:

More actions

 

And if we try to suspend/deactivate the user with Okta APIs, the error "Cannot suspend/deactivate a managed user. Try ending privileged access." is returned:

Postman

Applies To

  • Service Accounts
  • User Lifecycle Management

Cause

This behavior is by design. Admin should not be allowed to suspend/deactivate Okta SA users.

Solution

To suspend/deactivate a user account managed with Privileged Access, first end Privileged Access for that user. Ending Privileged Access will automatically deactivate the user.

 

Related References

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Okta Support - Unable to Suspend or Deactivate Service Accounts Managed by Okta Privileged Access