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Unable to Setup MFA for AWS AD Connector Due to RADIUS Server Communication Issue
Okta Classic Engine
Multi-Factor Authentication
Okta Identity Engine
Overview

Enabling Multi-Factor Authentication (MFA) for an AWS Active Directory (AD) Connector directory can fail. This is often due to a communication issue between AD Connector instances and the RADIUS server, which does not respond, preventing MFA configuration.

 

Sample Background Setup:

  • An admin has an AWS AD Connector set up to connect to Active Directory to AWS services (AWS Workspaces).
  • Attempting to enable MFA for the AD Connector using the Okta RADIUS server (IP: [IPAddress]) for authentication.
  • The MFA setup consistently fails, and no traffic reaches the Okta RADIUS server, or the logs don't indicate the cause of the failure.
Applies To
  • Okta RADIUS
  • Multi-Factor Authentication (MFA)
Cause

Okta RADIUS Agent App is being blocked from Windows firewall.

Solution

To resolve the issue, follow the steps mentioned below:

  1. Log in to Windows Server.
  2. Search Allow an app through Windows Firewall.

Allowed app

  1. Click Allow another app.
  2. Click Browse to C:\Program Files (x86)\Okta\Okta RADIUS Agent\current\bin folder.
  3. Open or upload these two files: Oauth and okta-radius, and click Add.

Okta RADIUS

  1. When the file okta-radius is uploaded or added, it will show as "Apache Commons Daemon Service Runner." Then click Add.
  2. Ensure that the allowed app and features "Oauth" and "Apache Commons Daemon Service Runner" are checked, and that the corresponding columns under Public are checked.

Allowed apps and features

  1. Then Hit OK.
  2. (Optional) Run a test using the NTRadPing application to verify that a response is received from the RADIUS Server to the AWS Workspace.

 

Related References

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Unable to Setup MFA for AWS AD Connector Due to RADIUS Server Communication Issue