Unable to Map to the Name Attribute in Active Directory From Okta
Last Updated:
Overview
Okta cannot map attributes to the name attribute in Active Directory because it is a read-only, system-only, optional attribute that ties to the full name and common name. Active Directory requires direct updates to the full name attribute to change a user's name attribute.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Active Directory
- Profile Mappings
Cause
Okta cannot map the name attribute to Active Directory because it is a read-only, system-only, optional attribute. The name attribute ties directly to the full name attribute and reflects the full name attribute when Active Directory creates an object. The name attribute also ties to the common name (cn).
Solution
What is the process to update the name attribute in Active Directory?
Update the user's name attribute directly in Active Directory by editing the full name attribute.
