<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Unable to Add a Identifier to User Profile Policy Error: "The rule could not be updated because the field email is hidden or read only and cannot be added to the form"
Directories
Okta Identity Engine
Overview

If the "Multiple Identifiers" feature is enabled, the Identification tab is available for each policy, and a unique attribute can be added to the user profile policy as the identifier. However, the user profile policy configuration fails with the following error message:


The rule could not be updated because the field email is hidden or read-only and cannot be added to the form

 

Add identifier

Applies To
  • Okta Integration Network (OIN)
  • Okta Identity Engine (OIE)
  • Multiple Identifiers
Cause

If the email attribute permission is configured as read-only or hidden, the identifier cannot be added to the user profile policy.

Solution

Change the email attribute to ensure the permission is configured as read-write.

Primary email

Loading
Unable to Add a Identifier to User Profile Policy Error: "The rule could not be updated because the field email is hidden or read only and cannot be added to the form"