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The sendEmail=false parameter Is Ignored in API Call for Activate User
Okta Classic Engine
Okta Identity Engine
Administration
Overview

The goal of this knowledge article is to explain why a user might receive an activation email after an Administrator runs the Activate User API call with the sendEmail=false parameter.

Applies To

 

  • Okta Classic Engine
  • Activate User API
  • Self-service registration
Cause

The user was created using the self-service registration flow and has not yet completed activation by verifying their primary email address.

Solution

This is expected behavior.

 

The reason the user is receiving the email is because the user was created using the self-service registration flow.

 

Because the user has not verified their email yet, the activation email will be resent until the user is activated.

Related References

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The sendEmail=false parameter Is Ignored in API Call for Activate User