<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Validation for LDAP Integration Fails when UID Does Not Use Email Format
Okta Classic Engine
Directories
Okta Identity Engine
Overview

If the LDAP uid attribute does not use an email format - the default format for the Okta username (user.login) - then user validation may fail with an error message:

 

Please review the form to correct the following errors:

  • Example username: Username must be in the form of an email addressError Message 
  • The Example username field must follow the format restrictions configured for the Okta username attribute (user.login)
Applies To
  • Lightweight Directory Access Protocol (LDAP)
  • User ID
  • Format Restrictions
Cause

When modifications are made to an existing Lightweight Directory Access Protocol (LDAP) integration, a test user must be validated before the configuration can be saved. This is meant to protect the LDAP Integration, but it can also cause confusing problems with its design.

Solution

To resolve the above error, change the format restrictions for the Okta username.

  1. Go to Admin > Directory > Profile Editor, and click the Okta (default) user type.

 Profile Editor 

  1. On the row for the Username attribute, click the Info icon. 

Info icon for Username attribute

  1. Next to Format restrictions, click the dropdown and change the restriction to None.

 format restrictions 

  1. Click Save Attribute.
  2. Go to Admin > Directory > Directory Integrations > [LDAP] > Provisioning > Integration, and test the validation field with a known user UID.
  3. The user should validate.

 Validate Configuration   

NOTE: This change may be reverted directly after validation and must not be permanently modified. 

Loading
Validation for LDAP Integration Fails when UID Does Not Use Email Format