<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Telephony Inline Hook with Twilio Error "Custom Code not allowed"
Multi-Factor Authentication
Okta Identity Engine
Overview

When trying to integrate Telephony Inline Hook with Twilio, the following error is encountered:

 

Custom Code not allowed.

 

Applies To
  • Multi-factor Authentication (MFA)
  • Telephony Inline Hook
  • Twilio
  • Okta Identity Engine
Cause

Custom Verification Code in Twilio Console is not configured properly.

Solution
  1. For an existing Service, enable Custom Verification Code in the Twilio Console by navigating to Verify > Services and selecting the Service. This will open the Service settings page.
  2. Select the existing Service under Friendly Name.
  3. Go to the General tab and scroll down to Code configuration.

    General tab 

  4. Check/enable the Enable Custom Verification Code option for that Service.

    "Enable Custom Verification Code" option 

  5. Once enabled on the Service, follow the steps listed in Custom Verification Codes to submit custom verification codes.

 

 

Related References

Loading
Telephony Inline Hook with Twilio Error "Custom Code not allowed"