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Super Admin Role Has Not Been Granted, Even with "Automatically assign the super admin role to all newly created public client apps" Enabled
Okta Classic Engine
Okta Identity Engine
API Access Management
Overview

This article explains why the Super Administrator role is not listed on the Admin roles tab, even though the org has the Automatically assign the super admin role to all newly created public client apps option enabled under Settings > Account.

Applies To
  • Orgs with the Assign admin roles to public client apps feature enabled
  • API Services app
Cause

There are two potential causes:

  1. The API Services app was created after the above feature was enabled.
  2. The API Services app has not yet been granted an Okta API Scope
 
 
Solution
In order for the Super Admin role to appear on the Admin Roles tab for the API Services app, the application must be created after the Automatically assign the super admin role to all newly created public client apps option has been enabled, and the application was granted access to at least one of the Okta API Scopes.

Once an Okta API Scope has been granted to the app, the Super Administrator role should be visible on the Admin roles tab:
Admin roles tab showing that the Super Administrator role has been granted to the API Services app
 
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Super Admin Role Has Not Been Granted, Even with "Automatically assign the super admin role to all newly created public client apps" Enabled