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MFA Factor Can Not be Seen in List Factors API
Okta Classic Engine
Okta Identity Engine
Multi-Factor Authentication
Overview

This article is meant to bring some clarity over the inconsistencies between what factors can be seen enrolled for an end-user in the Admin UI and the factors that can be seen when calling the List Factors API for that end-user.

Applies To
  • Okta Classic Engine
  • Okta Identity Engine
  • Factors API
  • MultiFactor Authentication (MFA)
Cause

Even though all the factors that the end-user is enrolled in can be seen via the Admin UI, if trying to call the List Factors API call, only the factors enabled in the Enrollment Policy being accessed by the end-user (set as Optional or Required) will be visible.

Solution

Make sure that the end-user is assigned to an Enrollment Policy that has all the required factors enabled prior to making the List Factors API call.

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MFA Factor Can Not be Seen in List Factors API