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Smartsheet Provisioning Flow Fails with Error "Error while reactivating user <username>: You do not have permission to perform the requested action."
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Smartsheet provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Smartsheet failed: Error while reactivating user <username>: You do not have permission to perform the requested action

 

Applies To
  • Smartsheet
  • Provisioning
  • Error
Cause

The account used for creating the API connection does not have the correct permissions to perform the requested action on the Smartsheet side. 

 

Solution
  1. Reach out to the Smartsheet account administrator or the Smartsheet support team to verify the permissions of the account used to create the API connection.
  2. Afterward, go to Okta Admin Console and navigate to Applications > Applications > Smartsheet > Provisioning > Integration > click the Edit button.
  3. Enter the Smartsheet valid API access token into the API Token field.
  4. Click Test API Credentials, verify the connection was successful, and then click Save
  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  6. After identifying the failed task for the user that should be retried, click on Retry Selected.

Related References

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Smartsheet Provisioning Flow Fails with Error "Error while reactivating user <username>: You do not have permission to perform the requested action."