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Smartsheet Provisioning Flow Fails with Error "apiErrorCode=2028, apiErrorMessage=Your account has been blocked by your account Administrator"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Smartsheet provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Smartsheet failed: Error while verifying if user <username> exists: apiErrorCode=2028, apiErrorMessage=Your account has been blocked by your account Administrator. Please reach out to them for assistance
 

Error

Applies To
  • Smartsheet
  • Provisioning
  • Error
Cause

The account used for creating the API connection is blocked in Smartsheet.

Solution
  1. Reach out to the Smartsheet account admin or the Smartsheet support team to verify the permissions and the status of the account used to create the API connection.
  2. Afterward, go to Okta Admin Console and navigate to Applications > Applications > Smartsheet > Provisioning > Integration > click the Edit button.
  3. Enter the Smartsheet valid API access token into the API Token field.
  4. Click Test API Credentials, verify the connection was successful, and then click Save.
  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  6. After identifying the failed task for the user that should be retried, click on Retry Selected.

Related References


 

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Smartsheet Provisioning Flow Fails with Error "apiErrorCode=2028, apiErrorMessage=Your account has been blocked by your account Administrator"