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Smartsheet Group Push Error "Unable to update Group Push mapping target App group. Errors reported by remote server: An unexpected error has occurred"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Okta admins may run into issues where they cannot push groups to Smartsheet and receive the following error:

 

Unable to update Group Push mapping target App group <groupName>: Error while creating user group <groupName>. Errors reported by remote server: An unexpected error has occurred. Please submit a support ticket at https://help.smartsheet.com/contact/smartsheetapp.

 

Applies To
  • SCIM Provisioning
  • Okta Integration Network (OIN)
  • Smartsheet SCIM OIN app
  • Group Push
Cause

A group with the same name already exists in Smartsheet. This behavior is expected as the Smartsheet OIN app does not support Group Linking.

Solution

Smartsheet supports groups created in Okta and that includes changes and updates. For push groups, the SCIM endpoint should be V3 and not V2. To correct this:

  1. Go to the Provisioning tab and select Configure API Integration.
  2. Select Enable API Integration and provide the Base URL: 
  1. Remove the existing group in the target app and try group push again.
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Smartsheet Group Push Error "Unable to update Group Push mapping target App group. Errors reported by remote server: An unexpected error has occurred"