Slack Provisioning Flow Fails Error "Bad Request. Errors reported by the connector : {"Errors":{"description":"email_invalid","code":400}}. Error Code: null"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Slack provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Slack failed: Error while creating user <username>: Errors during execution: Error executing createNewUser: Bad Request. Errors reported by the connector : {"Errors":{"description":"email_invalid","code":400}}. Error Code: null
 

Applies To
  • Slack
  • Provisioning
  • Error
Cause

Based on Slack's documentation, this error is thrown because the provided user email values are invalid.

error 

Solution
  1. Go to ApplicationsApplications > Slack > Assignment tab > click the pencil of the user > verify if the provided user email values are valid.
  2. If the provided user email values are valid, then please contact Slack support to check if the user is blocked on the Slack end and/or if the email domain for the impacted user is on the Slack blocklist.
  3. Afterward, attempt the user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
Tasks
  1. After identifying the failed task for the user that should be retried, click Retry Selected.

 

Related References

 

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