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ServiceNow Provisioning Error: "Unable to map response to an object"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

ServiceNow UD provisioning flow fails with the following error visible in the Okta dashboard:

 

Automatic provisioning of user <username> to app ServiceNow UD failed: Unable to map response to an object

 

Applies To
  • ServiceNow UD
  • Provisioning
  • Error
Cause

The ServiceNow UD account used for creating the API connection does not have the correct permissions on the ServiceNow side. The ServiceNow account needs administrator permissions for the organization.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > ServiceNow UD > Provisioning > Integration > click the Edit button. 
  2. Enter the ServiceNow API Credentials:
    • Admin User Name: Enter a ServiceNow username with administrator permissions for the organization.
    • Admin Password: Enter a password for the administrator account (above).     
  3. Click Test API Credentials, verify if the connection was successful, and click Save.
  4. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

    Tasks 
  5. After identifying the failed task for the user that should be retried, click on Retry Selected

Related References

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ServiceNow Provisioning Error: "Unable to map response to an object"