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ServiceNow Assignment Groups are Not Syncing in OIG Access Requests
Okta Classic Engine
Identity Governance
Okta Identity Engine
Overview

In the Okta Access Requests console, after successfully connecting the ServiceNow Integration under Settings > Integrations, none or only some of the ServiceNow groups are synced to the Assignment groups under the Settings > Resources tab in Access Requests.  When attempting to sync the groups using the Update now button, the following message is displayed, but none of the groups (or only a subset of the groups) get synced:

 

Assignment groups successfully queued for refresh.

 

Displayed Message

Applies To
  • Okta Identity Governance (OIG)
  • OIG Access Requests
  • ServiceNow Assignment Groups in Access Requests
Cause

This can occur for the following reasons, but may not be limited to just these scenarios:

  1. One or more groups in ServiceNow that do not have a name.  ServiceNow allows for the creation of groups that do not require a name.  The Assignment groups are displayed in Access Requests using the group name.  Groups without a name will prevent the Assignment group sync from completing successfully.  
  2. The ServiceNow account used to configure the ServiceNow connection in Access Requests does not have permissions to execute the /api/now/table/sys_user_group API.  In this case, no groups will be synced to Access Requests.
  3. Child groups in ServiceNow do not get synced to Access Requests.  This is expected behavior, but it will not prevent the sync from running successfully.
Solution

Troubleshooting steps to assist with resolving the issue:

  1. Make sure the ServiceNow account that was used to connect the ServiceNow integration in Access Requests is able to execute the /api/now/table/sys_user_group API using a tool like Postman.  If no groups are returned, the account may not have permissions to execute the API.
  2. Check the list of groups in ServiceNow to see if there are groups without a name. To identify these groups, the Name column will be populated with "(empty)". These groups will prevent the sync from completing successfully and must be given a name.
  3. If specific groups are not syncing to Access Requests, check in ServiceNow to see if they are child groups. To identify child groups, the Parent column in the list of groups in ServiceNow is populated with a value other than "(empty)". Child groups are not synced to Access Requests.

Related References

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    ServiceNow Assignment Groups are Not Syncing in OIG Access Requests