<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
SCIM Provisioning Returns Error Sync User in External Application Failure
Okta Classic Engine
Okta Identity Engine
API Access Management
Overview

After provisioning is configured, trying to sync users from Okta is logging the below error in system logs,

Sync user in external application 
FAILURE:
Applies To
  • OIE / Classic
  • SCIM Provisioning
Cause

There are a number of reasons that SCIM servers might return errors during a provisioning event. In most cases, logging on the SCIM server side will provide more details, or the SCIM server will return some sort of error response to Okta.

There is a specific case where often no meaningful error will be returned to Okta. The SCIM provider might even report not seeing the request from Okta at all. This can happen if the http/application server SCIM is running on is not configured to allow requests where the HTTP Accept header is set to 'application/scim+json'.

When Okta sends a provisioning request to SCIM, the following http headers will be sent.

Accept : application/scim+json
Accept-Charset : utf-8
User-Agent : Okta SCIM Client 1.0.0
Solution

Verify if the HTTP/application server can handle requests with the HTTP Accept header of application/scim+json. If not, add this as an allowable Accept type.

Loading
SCIM Provisioning Returns Error Sync User in External Application Failure