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SAML Assertion Token Exchange Flow Receives "SAML Assertion credentials cannot be used with MFA enabled" Error
API Access Management
Okta Identity Engine
Overview

Receiving the following error when attempting a SAML Assertion Token Exchange Flow:

 

SAML Assertion credentials cannot be used with MFA enabled.

 

Applies To
Cause

There are a few possible causes:

  • The SAML IdP configuration is configured to Trust Claims from the SAML IdP, and the IdP is not sending the claim.
  • The Application Sign-On Policy used by the OIDC Application for the Token Exchange requires a higher level of assurance than Password/IdP.
  • Progressive Profiling is being triggered for a missing attribute required by the User Profile policy, the OIDC Application for the Token Exchange is assigned to.
Solution
  1. Edit the SAML IdP Configuration being used for the Token Exchange (Security > Identity Providers > select the used SAML IdP > Edit IdP).

Perform one of the following actions: 

    • Disable both of the following options under Authentication Settings:
      • Trust claims from this identity provider
      • Trust AMR claims from this identity provider

General settings

 

 

  1. Edit the Application Sign-On policy (Security > Authentication Policies > App Sign In > Edit). Verify the rule is set to Password/IdP only.

Password/IdP

NOTE: The Global Session Policy Configuration does not apply; only the Application Sign-On policy needs to be set to Password/IdP.

 

  1. Ensure the OIDC application is assigned to a User Profile policy that does not allow progressive profiling.

 user profile policy

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SAML Assertion Token Exchange Flow Receives "SAML Assertion credentials cannot be used with MFA enabled" Error