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Salesforce Provisioning Error "unable to obtain exclusive access to this record"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Salesforce provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Salesforce.com failed: unable to obtain exclusive access to this record

 

Applies To
  • Salesforce
  • Provisioning
  • Error
Cause
This error is usually caused by a temporary failure on the Salesforce side due to another process modifying the user at the same time when the user is being accessed by the Okta provisioning.
Solution
 
  1. After some time, attempt the failed task again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks
  2. After identifying the failed task for the user that should be retried, click on Retry Selected to see if it resolves the error.
  3. If the error is still there, try to fix this issue by re-assigning the user to the application, which should provision the user successfully.
  4. If the issue still persists, then please contact Salesforce support for more details and steps on how to resolve this error.
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Salesforce Provisioning Error "unable to obtain exclusive access to this record"