<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Salesforce Provisioning Error "invalid cross reference id"

Okta Integration Network
Okta Classic Engine
Okta Identity Engine

Overview

When pushing Profile Updates to Salesforce, the following error may be encountered:
 

Automatic profile push of user <username> to app Salesforce.com failed: invalid cross reference id
 

Error

 

Applies To

  • Salesforce
  • Profile Update
  • Provisioning

Cause

After a Salesforce sandbox refresh, some users have different Salesforce User IDs, which are linked to External IDs; this breaks the connection for the user between Okta and Salesforce.

Solution

  1. Unassign the User from the Application.
  2. Reassign the User to the Application.
  3. Confirm they have been provisioned without errors.
Loading
Okta Support - Salesforce Provisioning Error "invalid cross reference id"