Salesforce Provisioning Error "Automatic provisioning of user to app Salesforce.com failed: No such column ProfileId on sobject of type User"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Salesforce provisioning flow fails with the following error visible in the Okta dashboard:


Automatic provisioning of user <username> to app Salesforce.com failed: No such column 'ProfileId' on sobject of type User

 

Applies To
  • Salesforce
  • Provisioning
  • Error
Cause

This error can be caused by trying to send data to a Salesforce field that has been deleted or modified. Salesforce app data has not been updated in Okta and needs to be refreshed.

Solution

Refresh application data by re-authenticating API credentials used for provisioning to/from Salesforce, which will download and update application data into Okta.

  1. Go to the Okta admin panel and navigate to Applications > Salesforce > Provisioning > Integration > Edit.
  2. Enter the OAuth Consumer Key and OAuth Consumer Secret. See Configure OAuth and REST integration for more details.
    • OAuth Consumer Key: Consumer Key from Salesforce OAuth settings.
    • OAuth Consumer Secret: Consumer Secret from Salesforce OAuth settings.
  3. Click Re-authenticate with Salesforce.com.

Re-authenticate with Salesforce.com

  1. In the new Salesforce.com window, enter the administrator username and password that were used to create the Connected OAuth App.
  2. Click Allow to permit access to the Connected App.
  3. On the Provisioning page in Okta, a message confirming successful authentication will be displayed. Click Save.
  4. Afterward, attempt the user provisioning again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks

  1. After identifying the failed task for the user that should be retried, click Retry Selected.

 

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