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RingCentral IdP-Initiated SSO Shows "Unexpected Error"
Single Sign-On
Okta Identity Engine
Overview

This article provides information on how to troubleshoot the following error that may occur when attempting to authenticate into RingCentral via Identity Provider (IdP) initiated Single Sign-On (SSO) flow, which happens upon clicking the tile in the Okta dashboard.

 

Unexpected Error

Sorry for the inconvenience. Please contact your administrator to provide the reference number below in order to find the corresponding error.

 

Error Message

Applies To
  • RingCentral
  • Single Sign-On (SSO)
  • Identity Provider (IdP)
  • Okta Identity Engine
Cause

The Default Relay State in the RingCentral Application template located in the Okta Integration Catalogue is not set to the correct value. 

Solution

Ensure the Default Relay State for the Ring Central application in Okta is configured as recommended in How to Configure SAML 2.0 for RingCentral.

Default Relay State:

https://service.ringcentral.com/mobile/ssoLogin

 

Steps to Configure

  1. Access the Okta Admin Console
  2. Navigate to the Ring Central application via Applications Applications
  3. Click the Authenticate tab
  4. Click Edit in the Sign-on settings section to review the SAML 2.0 configuration
  5. Enter the relevant value for the Default Relay State (see Related References below)

Default Relay State

  1. Click Save

 

Related References

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RingCentral IdP-Initiated SSO Shows "Unexpected Error"