<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Revoking Tokens to First Party Apps Like Okta Dashboard That Require the clientID
API Access Management
Okta Classic Engine
Okta Identity Engine
Overview

First-party apps like the Okta Dashboard or Okta Admin Console have a client ID different from the App ID. Passing the App ID of First Party Apps as the Client ID in the request results in a 404 with the error summary:

 

Not found: Resource not found: 0oa... (PublicClientApp).

 

This can occur if the App ID is mistakenly used instead of the Client ID when revoking refresh tokens issued for the specified User and Client.

Postman

 

The request works when the App ID matches the Client ID (such as for a custom OpenID Connect application).

Applies To
Cause

This is by design, since the Revoke All Refresh Tokens API expects the Client ID.  

Solution
  1. To identify the Client ID for First Party Apps like the dashboard or Okta Admin Console, search the system log for a token grant or authorization request for the relevant app.

System log

 

  1. The Client ID can be found under Actor > ID.

System log expanded

 

  1. Call DELETE on /api/v1/users/${userId}/clients/${clientId}/tokens with the Client ID.

Postman API call

Loading
Revoking Tokens to First Party Apps Like Okta Dashboard That Require the clientID