Okta Access Gateway Fails To Renominate Previous Admin Node With Version Information Error
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Overview
An Okta Access Gateway (OAG) cluster fails to renominate a previous admin node as the admin node due to incorrect file permissions on the version compatibility file. Removing the file or changing its permissions resolves the issue.
When renominating the original admin node as the admin node again, the process fails with the following error message:
Failed to get version information for package - okta-mgmt-user from worker nodes
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Okta Access Gateway (OAG)
- Admin Renomination
Cause
During the admin renomination process, Okta Access Gateway checks version compatibility between the admin and the worker node. This flow creates a file named /tmp/version_compat.txt with root:root permissions on the current admin node and the same file with oagha:oaghagrp permissions on the worker node being nominated.
When adding the previous admin node to the High Availability (HA) cluster and attempting to renominate it as an admin node again, the process fails to read the /tmp/version_compat.txt file. The process uses the oagha user, which cannot read the file with root permissions. A reset, reinitialize, and reboot does not resolve the issue, as the initialization process does not delete the file.
Solution
How is the admin node renomination error resolved?
Access the appliance shell to either remove the version compatibility file or change its permissions, and then rerun the renomination process.
- Log in to the appliance shell.
- Choose one of the following methods to resolve the file permission issue on the original admin node:
- Remove
/tmp/version_compat.txtfile on the original admin node with root permissions by running the provided command.sudo rm /tmp/version_compat.txt
- Alternatively, change the file permissions to
oagha:oaghagrpby running the provided command.sudo chown oagha:oaghagrp /tmp/version_compat.txt
- Remove
-
Run renomination again.
