Ramp Provisioning "Error while creating user <username>: Bad Request. Errors reported by remote server: No department provided"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Ramp provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Ramp failed: Error while creating user <username>: Bad Request. Errors reported by remote server: No department provided

 

Applies To
  • Ramp
  • Provisioning
  • Error
Cause

The Ramp SCIM server reports the error. 

According to the Ramp Configuration Guide, the Department attribute value will be used to set the user’s department in Ramp. If the department does not exist in Ramp, it will be automatically created.
If Ramp receives a request to create or update a user with no department set, it will be rejected.

department

Solution
  1. Check the User's App User Profile to confirm that the Department attribute has a value as expected on the Ramp side. 
  2. Then, attempt the user provisioning again. Go to the Okta admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  3. After identifying the failed task for the user that should be retried, click on Retry Selected.
  4. If the issue persists, please contact Ramp support for more information and guidance on resolving this error.


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