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Provisioning Users through Org2Org - Users Are Imported with Email as Username
Okta Identity Engine
Okta Integration Network
Overview

It was noticed that when provisioning users through an Org2Org integration, it imports the users' email as a username instead of the actual username or vice versa. This article explains why this is happening and how to resolve this issue.

Applies To
  • Org2Org Provisioning
  • Okta Identity Engine (OIE)
Cause

This behavior is controlled through a configuration setting.

Solution

To address this scenario:

  1. Go to the Org2Org application.
  2. Navigate to the Provisioning tab.
  3. On the Integration section, make sure that the box for Prefer Username over Email is checked.

"Prefer Username over Email" option

    • This feature is used only for importing user(s), specifically for deciding which value should be set as the imported user username: email (the feature is disabled) or username (the feature is enabled).
    • NOTE: This does not change any App Username Mappings. See Override an app username.

 

Related References

 

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Provisioning Users through Org2Org - Users Are Imported with Email as Username