Application Provisioning Error "Unauthorised. Errors reported by remote server: Token is invalid or expired"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Application provisioning flow fails with the following error visible in the Okta dashboard:

 

Unauthorized. Errors reported by the remote server: Token is invalid or expired.

 

Applies To
  • Porvisioning
  • Okta Integration Network
  • API Token
Cause

The Service Account used for creating the API connection does not have the appropriate permissions on the application side or the API Token is Expired. The Service account requires appropriate permissions for the organization, please refer to the Provisioning Documentation under the Provisioning tab > Integration Settings for the specific App encountering this message.

Solution
  1. Correct the Permissions or renew the API Token on the Application side first, refer to the Provisioning Documentation under the Provisioning Tab > Integration Settings.
  2. Go to Okta Admin Console and navigate to Applications > Applications > [AppName] > Provisioning > Integration > click the Edit button.
  3. Enter the Service Account API Credentials:
    • Admin User Name: Enter the Service Account username with administrator permissions for the organization.
    • Admin Password: Enter a password for the administrator account (above).  
  4. (If the Provisioning is not requesting an Administrator User Name and a Password) Click on Re-authenticate API Credentials to verify the connection was successful, and then click Save.
  5. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks 

rtaImage.png 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

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