カスタム認可サーバー経由でOpenID Connectアプリにログインすると、「この要求に対するポリシー評価は失敗しました」というメッセージが表示される
API Access Management
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Overview

ユーザーがカスタム認可サーバーからトークンを取得しようとすると、次のエラーが表示される場合があります。

 

この要求に対するポリシー評価は失敗しました。ポリシー構成を確認してください。

 

このエラーはコールバックルートに返され、ユーザーは正常にログインできなくなります。

Applies To
  • OpenID Connectアプリケーション
  • カスタム認可サーバー
  • アクセスポリシー
  • アクセスルール
Cause

このエラーは、新しいカスタム認可サーバーを設定するとき、または既存のカスタム認可サーバーを構成するときに、いくつかの理由で発生する可能性があります。

  • カスタム認可サーバーに、適切なアクセスポリシーおよびルールがない。
    カスタム認可サーバー  
  • 既存のアクセスポリシーまたはルール非アクティブである。

カスタム認可サーバーにあるアクセスポリシーやルールが非アクティブである。

  • クライアントアプリケーションが、既存のアクセスポリシーに割り当てられていない。

クライアントアプリケーションが割り当てられていない

 

アプリケーションでカスタム認可サーバーからトークンを取得するには、トークンリクエストを許可するルールが設定されたアクティブポリシーにアプリケーションを割り当てる必要があります。

Solution

これを修正するには、カスタム認可サーバーに対してアクセスポリシーとそれに対応するアクセスルールが正しく構成されていること、およびアプリケーションがポリシーに割り当てられていることを確認する必要があります。

  1. カスタム認可サーバーのアクセスポリシーを作成します。
  2. そのポリシー内にアクセスルールを作成します。
  3. アクセスポリシーアクセスルールの両方がアクティブであることを確認します。
  4. クライアントアプリケーションを新しいアクセスポリシーに割り当て、認可サーバーを使用できるようにします。

この認可サーバーの使用を開始するには、アクセスポリシーと付随するアクセスルールを作成します。

 

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