PagerDuty Provisioning "Error while creating user <username>: Access Denied (2010)"
Last Updated:
Overview
PagerDuty provisioning flow fails with the following error visible in the Okta dashboard:
Automatic provisioning of user <username> to app PagerDuty failed: Error while creating user <username>: Access Denied (2010)
Applies To
- PagerDuty
- Provisioning
- Error
Cause
This error is due to the API token used for creating the API connection not having the correct permission on the PagerDuty side.
Solution
Please follow the video or steps below:
- Go to Okta Admin Console and navigate to Applications > Applications > PagerDuty > Provisioning > Integration > Edit.
- Enter the new API key with the Full Access Level that was generated in the PagerDuty Administrator Portal in the API Token field.
- Enter the admin username with admin or owner permissions in the Admin Username field.
- Click Test API Credentials, verify the connection was successful, and then click Save.
- Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
- After locating the failed task for the user that should be retried, click on Retry Selected.
