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How to Fix the "403 Forbidden" Error when Using the Search Systems Logs Card
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

This how-to guide presents how to fix the 403 Forbidden error when using the Search Systems Logs card.

Error Example:


scope=\"okta.logs.read\",
error=\"insufficient_scope\", error_description=\"The access token provided does not contain the required scopes.\",
resource=\"/api/v1/logs\"




The Okta – Search Systems Logs card allows searching in the Okta log by a keyword (and also an expression, set in Options):

Search Systems Logs card.
Search Systems Logs card  

When running a flow with this card, it might return a 403 Forbidden error:

403 Forbidden error with Search Systems Logs card.
Error Mesage  
 

Applies To
  • Okta Workflows
  • Okta worklfows connection
  • Okta Workflows Connection - Insufficient Scope
Cause
This can be due to the scope okta.logs.read was not originally granted in the Okta workflows OAUTH app OR the permissions tab while reauthorizing the connection was not reviewed confirming the proper selection(s).
Solution

Video walkthrough of the steps written below:


 

To fix this error, grant an additional scope to the Okta connection.

  • Grant the okta.logs.read scope in the new permissions tab using custom scopes while reauthorizing the connection

OR
 

  1. From the Admin Console, go to Applications > Applications.
  2. Click Okta Workflows OAuth.
  3. Open the Okta API Scopes tab.
  4. Find the okta.logs.read scope and click Grant.
  5. For this scope to take effect, reauthorize the connection that is being used.

Granting a scope to a connection


After reauthorizing the connection (to include reviewing the permissions tab), rerun the flow. The card is now able to search the logs:

Search Systems Logs card


Thanks to Bryan Barrows (LinkedInblog), who helped with this question on the MacAdmins Slack channel.


Related References

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How to Fix the "403 Forbidden" Error when Using the Search Systems Logs Card