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ERROR "The request was not valid: User is not in org" When Using OIG API V1 for Access Requests
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

When using the Okta Identity Governance API for Access Requests V1 (/governance/api/v1/requests or /governance/api/v1/request-types) an error may occur:

{
  "body": {
    "errorCode": "E0000002",
    "errorSummary": "The request was not valid: User is not in org <ORGINFO> (subdomain: <ORGINFO>)",
    "errorLink": "E0000002",
    "errorCauses": [],
    "errorId": "417e2bf6ac14491289218c34c842e841"
  },
  "message": "400 Bad Request",
  "description": "HTTP Request Error"
}


 

Applies To
  • Okta Identity Governance API
  • Access Requests V1 API
  • Okta Workflows
Cause

This may be because the user who created the token or Okta Workflows Connection was not assigned to the Access Request application.

Solution

To use the Okta Identity Governance API for any Access Request V1 actions, the user tied to the request should be assigned to the Okta Access Request application. It may be helpful to use a Service Account to create the token/connection. 

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ERROR "The request was not valid: User is not in org" When Using OIG API V1 for Access Requests