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Okta Verify Push Notifications Not Working and FastPass Fails with Invalid Credentials
Multi-Factor Authentication
Okta Identity Engine
Overview

When an end-user authenticates with Okta Verify by using the Push factor, the verification can fail because the notification was not received.

In this scenario, it is recommended to check the clock skew between the end-user's device and the server. If the device clock is incorrect, it can result in failed deliveries or invalid codes.

Applies To
  • Multifactor authentication (MFA)
  • Okta Verify Push
  • Okta Verify FastPass
  • Okta Identity Engine (OIE)
Cause

This issue can be encountered when the device time is out of sync with the server time. 

Okta Verify logs show:

 

Authorization Error: Issued at time is invalid corresponding to the current time,
Description: Authorization Error: Issued at time is invalid corresponding to the current time


 Review the article on how to Collect Okta Verify Logs from Desktop (macOS / Windows.

Solution

When Okta requests an OTP code, the server and the device need to be synchronized to ensure that the generated code matches the one expected by the server. By setting the device to automatic date and time settings, the device’s clock is ensured to be synchronized with a reliable time source, such as an internet time server. This synchronization ensures that the generated OTP codes align with the Okta server's expected codes.

Ensure that the device has the correct time and set the time to automatic.

Steps

  1. Set the device time to automatic.
  2. Clear the cache and cookies in the browser.
  3. Close the browser.
  4. Try again.

 

iOS - Okta Verify

  1. Navigate to Settings > General > Date and Time.
  2. Select Set Automatically.

 

Android - Okta Verify

  1. Navigate to Settings > Date & Time.
  2. Select Automatic.

 

Windows - Okta FastPass

  1. Open the Start menu and click Settings.
  2. Click Time & Language on the Settings dialog box.
  3. Scroll to the Related Settings section and click Additional date, time & regional settings.
  4. The Clock and Region screen in the Control Panel displays.
  5. Click Date and Time.
  6. Click the Internet Time tab on the Date and Time dialog box.
  7. Click Change settings.
  8. On the Internet Time Settings dialog box, check the Synchronize with an Internet Time server box.
  9. Select a Server from the drop-down list.
  10. If the server is not listed, type the name of an Internet time server. The time servers can be found on Microsoft’s site.
  11. Click Update now.

 

macOS - Okta FastPass

  1. On the macOS, choose Apple menu > System Settings.
  2. Click General in the sidebar, then click Date & Time on the right. 
  3. Turn on Set time and date automatically, select Set, then enter a network time server for the region.
  4. Turn on Set time zone automatically using your current location.
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Okta Verify Push Notifications Not Working and FastPass Fails with Invalid Credentials